Problème RPI 3 + carte 8 relais + JEEDOM


Messages recommandés

Salut tout le monde, 

Je possède actuellement un Raspberry Pi 3 Model B+, ainsi qu'une carte Elegoo 5V 8 relais (compatible Rpi et Arduino) auquel est raccordé 8 prises électriques pour pouvoir gérer 8 appareils indépendamment (lampe 1, lampe 2, intra 1, extra 1, extra 2 etc..), j'attends une DHT22 également. 

Mon souci est, lorsque je me trouve sur Raspbian, je fais les commandes pour installer JEEDOM (en 11 étapes), jusque là tout se déroule bien. Mais je lis partout que je sais observer l'avancement de l'installation de Jeedom en tapant l'adresse IP du Rpi. et là, page indiquant que rien n'existe.

Du coup, je suis paumé sur le fait que je n'avance pas depuis quelques jours, je bute quelque part.
Et je me demande aussi que faire pour que mes GPIO soient reconnus pour que lorsque JEEDOM fonctionnera, faire toute la configuration.

Merci d'avance

Lien à poster
Partager sur d’autres sites

Merci beaucoup Gen, mtn je suis sur JEEDOM, j'ai acheté le plugin GPIO mais je suis perdu ensuite.

Penses tu savoir m'aider sur la config des GPIO (en out si je ne me trompe pas) ?

 

voici un schéma simplifié de mon install5a59f1915ad3e_Sanstitre.thumb.png.86208fc0c0befb3a0b154719c4370f99.png

Modifié par BilouteDj
Lien à poster
Partager sur d’autres sites

re:

 

Vraiment simplifié alors....

 

raccordement.png

 

 

rouge = phase

bleu = neutre

jaune = terre

 

Si tu câbles cela avec de 2,5mm², la conso globale ne peut pas dépasser 16A

Pour une lampe avec ballast, je te conseille l'utilisation d'un relais SSR

 

++

GEN

 

 

Lien à poster
Partager sur d’autres sites

Ok donc souci dans mon câblage (alim général sur la carte relais) chez moi en voyant ton dessin, merci je vais corriger tout ca de suite..
Oui je suis en 2,5mm², disjoncteur et tout ce qui va avec

SSR en direct sur la carte 8 relais ou alors directement au RPI ? 

 

En fait, je voudrais gérer: 2 lampes (CRO +Flo{ballast}), 1 intra, 1 extra, 1 humid, 1 refroidisseur, 1 ventillo brasseur, 1 extra pour mon cooltube.

Merci bcp de ton aide

Lien à poster
Partager sur d’autres sites

RE :

 

pour ton ssr c'est comme tu veux, il consommera +/- 7.5mA, à toi de voir combien tu risques de pomper au max sur ton RPI.

Tu peux même rajouter un optocoupleur pour plus de sécurité si tu veux

 

L'info suivante : 2 lampes (CRO +Flo{ballast}), 1 intra, 1 extra, 1 humid, 1 refroidisseur, 1 ventillo brasseur, 1 extra pour mon cooltube. m'est totalement inutile car je n'ai pas les puissances nominales max de chaque appareil..

 

++

GEN

Lien à poster
Partager sur d’autres sites

Avec quoi (et comment) pourrais-je programmer mes GPIOs qui gèrent mes "prises" ?
Je suis débutant, je gère quelques trucs sous Linux, mais là c'est au dessus de mes connaissances.
si tu sais m'aider ou autre, je suis preneur sache le :D
Merci d'avance

 

A+

Geo

 

PS: Je viens de revoir le lien que tu m'as envoyé que tout était bien suivi et je viens d'observer que cette ligne de commande

apt-get install python-requests

j'ai ceci avec PuTTy

pi@raspberrypi:~ $ apt-get install python-requests
E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock - open (13: Permission non accordée)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Avez-vous les privilèges du superutilisateur ?


 

Modifié par BilouteDj
Lien à poster
Partager sur d’autres sites

re :

 

essaie

sudo apt-get install python-requests

ensuite il te demandera ton mot de passe administrateur pour valider la commande

 

++

GEN

Lien à poster
Partager sur d’autres sites

@Gen

 

Impossible de retrouver mon Rpi sur Win10, donc je vais voir si il n'y a pas une éventuelle autre vidéo ou soluce.
Merci encore

@Ravier17

 

J'avais déjà été jeté un coup d'œil mais j'ai pu lire que Domoticz prenait dans sa config les pins en BMC tandis que sur Jeedom, c'est avec les Pins 'numérisation normale', du coup la config ne se fait pas totalement de la même manière je pense, à moins de me tromper

Lien à poster
Partager sur d’autres sites
  • 2 semaines après ...

Oui j'ai bien tout effectué 
gpio.png.6aef4ff6ce14761b094e057584474098.png

 

Maintenant sur JEEDOM j'ai acheté un plugin GPIO, mais impossible de voir un changement.

Ma question est: Est-ce possible que mon branchement de ma carte relais au Rpi soit mauvais ?
Sachant que les 8 relais sont connectés PIN 31 à 40, hormis le 34 qui est le GND et la PIN 2 pour le 5V de la carte relais.

Si ce n'est pas un souci de connexion, à quoi pensez-vous? et à quelle astuce avez-vous idée ?

Merci d'avance

Lien à poster
Partager sur d’autres sites

Salut,

 

tes GPIO 31 à 40 sont configurés IN hors, ta carte relais attend un signal pour fonctionner. Il faut donc que tes GPIO soit en out, pour qu'ils envoient un signal.

Il faut configurer les GPIO en IN uniquement pour les peripheriques envoyant un signal: les DHT par exemple ou sonde CO2 ou...

 

Tu trouveras tous les renseignement utiles en cherchant sur google par exemple :Configurer GPIO au demarrage

 

A+

 

Lien à poster
Partager sur d’autres sites
  • 3 semaines après ...

@Gen

non pas du tout, je n'y ai pas pensé. Je me suis dit, vu que la carte relais possède des diodes, cela suffirait.

@Ravier17

via le contrôleur GPIO sous JEEDOM, c'est bien ce que j'ai fait, mais aucune donnée n'est retenue en mémoire, je vais regarder cela de plus près, voir si le DHT va fonctionner également.

 

 

Lien à poster
Partager sur d’autres sites

 

Yop

Il y a 9 heures, BilouteDj a dit:

non pas du tout, je n'y ai pas pensé. Je me suis dit, vu que la carte relais possède des diodes, cela suffirait.

C'est pas faux, mais qu'est-ce qui te prouvait que ta platine relais est OK.

Je sais, c'est tiré par les cheveux, mais quand on 'débug" un problème électronique, on commence toujours par le point d'origine et on descend dans le circuit.

Crois moi, cela évite souvent des problème liés à des certitudes qui n'en sont pas ;-)

 

Bon montage

++

GEN

 

Lien à poster
Partager sur d’autres sites
Il y a 10 heures, BilouteDj a dit:

 

via le contrôleur GPIO sous JEEDOM, c'est bien ce que j'ai fait, mais aucune donnée n'est retenue en mémoire, je vais regarder cela de plus près, voir si le DHT va fonctionner également.

 

Salut,

Salut,

 

Essaye de parametrer les GPIO au démarrage du raspi. Il faut éditer je ne sais plus quel fichier (init.d ou RC.d) afin de mettre les GPIO en IN ou en OUT, cela évite pas mal de soucis par la suite. J'avais bien galérer pour que le DHT fonctionne correctement sur mon raspi.

 

A+

Lien à poster
Partager sur d’autres sites

Salut

l'utilisation de Jeedom est-elle necessaire ?

Tu peux utiliser une petite distri open source par exemple et la modifier selon ton contexte .

Pour exemple j'utilise raspiviv ( programme pour gérer le climat d'un vivarium) avec un RPi2 , carte 8 relais.

Le tout se pilote depuis une interface web . Je peux t'en dire plus si cela t’intéresse.

 

  • Like 1
Lien à poster
Partager sur d’autres sites
  • 1 mois après ...
Le 17/02/2018 à 12:45, lolo628 a dit:

Salut

l'utilisation de Jeedom est-elle necessaire ?

Tu peux utiliser une petite distri open source par exemple et la modifier selon ton contexte .

Pour exemple j'utilise raspiviv ( programme pour gérer le climat d'un vivarium) avec un RPi2 , carte 8 relais.

Le tout se pilote depuis une interface web . Je peux t'en dire plus si cela t’intéresse.

 

Oui bien évidemment, mon but est de pouvoir gérer mon placo de manière "autonome", bien sur sans oublier la main humaine qui fait 90% du tout.
Fais moi glisser un msg privé au pire pour qu'on puisse plus en discuter :D Merci l'ami

 

Lien à poster
Partager sur d’autres sites
Le 16/02/2018 à 09:13, Ravier17 a dit:

Salut,

 

Essaye de parametrer les GPIO au démarrage du raspi. Il faut éditer je ne sais plus quel fichier (init.d ou RC.d) afin de mettre les GPIO en IN ou en OUT, cela évite pas mal de soucis par la suite. J'avais bien galérer pour que le DHT fonctionne correctement sur mon raspi.

 

A+

J'ai pu créer un fichier en contrôlant un seul GPIO (donc tout mon branchement fonctionne), mais le souci est que ce n'est que la config ON/OFF en (html).

Maintenant je recherche comment configurer mes 9 GPIOs (8 Out et 1 IN) et quel logiciel utilisé ? SVP

Car sur Domoticz, je dois créer un script spécial à lui car si je fais sur rc.local ( sudo nano /etc/rc.local), ce fichier boot après Domo donc c'est mort.
J'ai acheté sur Jeedom à l'époque, l'appli GPIOs, et je sais qu'il existe bien mieux, pouvez vous m'aiguiller svp.

Merci d'avance

Lien à poster
Partager sur d’autres sites
  • 1 mois après ...

Hey, je reviens vers vous pour un peu plus d'explications.

Pour ce qui concerne la config des GPIOs, tout ok. J'ai pu créer et mettre en route mon fichier .py avec le script de chacun des GPIOs et leurs valeurs.
 

Mon souci et le dernier, comment puis je faire pour créer deux sondes virtuelles (T° et Hum) indépendamment ? 
J'ai essayé de suivre le tuto d'un d'entre nous (Lairdesvoges) mais ça ne fonctionne pas chez moi :/ 

Lien à poster
Partager sur d’autres sites

yop

 

Simple.. passe sur arduino MOUHHAHAHAHAA

 

Ok.. Pas besoin de me montrer la porte, je sors !

 

++

GEN

  • Haha 1
Lien à poster
Partager sur d’autres sites

Justement, cela me tente énormément et je suis prêt à investir. J'ai regardé pas mal de tes projets "fous" (encore celui posté aujourd'hui).

Que me conseillerais-tu ? Ou si tu as un tuto dans mes demandes mais via ce système, je suis preneur direct !

Merci à tous encore @Gen

 

++

Modifié par BilouteDj
Lien à poster
Partager sur d’autres sites