Growduino V3 pour un nul


Recommended Posts

Bonsoir,:respect:

Pour ma 2ème session indoor, je vais essayer d’utiliser un contrôleur. Du coup, j’ai passé une commande à @Gen, commande que j’ai reçue il y a quelques jours,  à savoir :

  • ·         1 arduino mega + shield growduino V3
  • ·         1 écran LCD 4x20
  • ·         1 platine moteur
  • ·         1 keypad
  • ·         1 sonde DHT
  • ·         1 platine relais 4 voies 

FONCTIONNEMENT

Avant de m’y mettre vraiment, je me pose quelques questions sur le fonctionnement du système sachant que dans un premier temps je souhaite gérer la température et l’hygrométrie.
Dans un second temps, je m’occuperai de la lumière.

Je possède les équipements suivants : un radiateur, un brumisateur, un extracteur et 2 ventilateurs.

J’imagine qu’en choisissant une température et une hygrométrie, le contrôleur va gérer le radiateur et le brumisateur mais quel(s) paramètre(s) gère(nt) l’extracteur et les 2 ventilos ?

Peut-on choisir une température et une hygrométrie différentes pour le jour et la nuit ?

 

 

ELECTRONIQUE/INFORMATIQUE

Et avant de mettre tout ça sous tension, j’aimerais m’assurer que ça ne crame pas  … ce serait quand même dommage !

Tout d’abord, j’ai tout mis sur la table, pris une photo et « étiqueté » les composants » pour faire valider ma compréhension.

 

Growduino01.jpg.d5d6ab7293788fda89e2f1064d59c737.jpg

Si j’ai bien compris, pour alimenter l’ensemble, je peux le faire de 2 manières :

  • -          Avec un cable USB entre un PC et la prise USB de l’Arduino Mega
  • -           Avec une alim 10-12 volts sur la prise jack de l’Arduino Mega

Question 1 : Est-ce correct et quelle alimentation puis-je utiliser ? Quel ampérage ?

    En fait, l'alimentation se trouve sur le shield Growduino, en 5 volt

Question 2 : Dois-je passer par la phase connexion avec un PC ou puis-je m’en passer ?

    Normalement, pas de modification de programme, donc pas besoin de PC

 

 

Pour gérer l’extracteur, j’ai déjà un auto-transfo qui convient, à mettre derrière la platine moteur :

 

AutoTransfo.jpg.e66417e8ef5058f50435a6c9c5377104.jpg

 

Par contre, pour gérer le ballast et la lumière il me faudra un relais SSR tel que celui-ci :  

RelaiSSR.jpg.e20bf8160672a0d3e1edef936adf78cc.jpg

-          FOTEK relais static 25A 3-32Vdc 24-380Vac SSR-25DA Relais stato solide SSR (5.95€)

Correct ? Pas de système de refroidissement car seulement 250W en cro et 400 W en flo.

 

 

Enfin, si je veux mettre l’ensemble dans un boitier en plastique, il me faudra un boitier IP65 de 35 x 25x 15.

Correct ? Non : boitier de 40xx30x17

 

Merci à l’avance de votre aide car même en ayant pas mal lu, je suis un peu dans le brouillard.

 

Peace. Cyberius. :kana_smile:

 

Edited by cyberius
En rouge, modif. suite à de nouvelles infos
  • Thanks 3
Link to post
Share on other sites

Yop

 

L'alimentation se fait via le connecteur du shield, il faut une alimentation de 5V 3A

Une fois sous tension, toutes tes questions trouveront réponses dans le menu.

 *= accès menu

Pas besoin de relier à un PC, l'arduino est déjà programmé, (verion logicielle pour sonde MH-Z14 & MH-Z19)

 

++

GEN

Edited by Gen
  • Like 1
Link to post
Share on other sites

Bonsoir,:respect:

 

J'avance tout doucement car j'ai bien compris qu'il y a du boulot et que n'étant pas électronicien je n'ai pas intérêt à me précipiter :shock:

 

Pour l'instant, j'ai fait un schéma général du système :

 

Growduino02.thumb.jpg.f1a5d5dd495aab536376ea9248f279d8.jpg

 

Je crois avoir (à peu près) inventorié les différents composants. J'ai commandé un boitier et l'alimentation.

 

A ce sujet j'avais lu qu'il fallait une alim de 5V 6A (que j'ai donc commandée) mais   ICI   Gen a indiqué 5V 3A.

Je crois que mon alim 5V 6A fera quand même l'affaire.

 

Je vais passer commande des autres composants qui me manquent mais j'ai un petit soucis car j'habite loin des villes et il n'y a pas de magasin d'électronique dans les environs.

Pas toujours facile de choisir ce qui convient par internet ! 

 

Un exemple (pourtant simple à priori) , je pense commander ces prises LA . Conviennent-elles ?  :rip:
Ces prises sont dites SCHUKO  (norme allemande qui devrait fonctionner en France).

 

Maintenant, je continue de collecter un max d'infos en attendant la réception de l'alimentation et du boitier ... pour passer à la pratique. :yepah:

 

Peace. Cyberius. :kana_smile:

 

 

 

 

 

 

Edited by cyberius
Correction schéma : la platine relai était mal connectée
  • Like 1
Link to post
Share on other sites

yop

 

Ton schéma est faux

la platine relais ne se branche pas sur les connecteurs SSR, mais sur le connecteur vert 10 pin nommé RELAIS

 

++

GEN

Link to post
Share on other sites
il y a une heure, Tracknar1234 a dit :

Salut ! 

 

Génial ! Merci 

 

Bise 

 

Le CHIEN 

Salut,

Félicitation tu as trouvé la piste à suivre.

Dans l'histoire le génial, tu l'auras deviné, c'est pas moi ... mais je m'accroche ... ça vaut le coup !

Peace. Cyberius.

  • Haha 1
Link to post
Share on other sites
il y a 51 minutes, Gen a dit :

yop

 

Ton schéma est faux

la platine relais ne se branche pas sur les connecteurs SSR, mais sur le connecteur vert 10 pin nommé RELAIS

 

++

GEN

Bonsoir Gen,

Merci d'être passé par là ... et de m'avoir fait remarquer ce bug:boulet1:. J'ai corrigé mon schéma ci-dessus... ça devrait être bon maintenant.

Pour les prises, j'ai un peu vu ce que sont les prises stucko et je vais les utiliser (plus belles en couleur et moins chères) à la place des prises françaises pour les équipements n'ayant pas besoin de prise de terre.

J'ai reçu le boitier (40x30x17) commandé il y a 3 jours seulement :applaus:... magnifique car je n'y ai pas encore touché.

 

Boitier01.jpg.0150a3b598c75679cc4aa153eae0aaad.jpgBoitier02.jpg.b19a064e49166d06f5cfb9904e9bcd68.jpg

 

Il faut que je me trouve du bon matos, genre Dremel que tu as cité, pour faire un travail propre. Parmi mes potes, je vais peut-être trouver ça.

 

In progress ...

 

Peace.Cyberius.

 

 

  • Like 1
Link to post
Share on other sites

Bonsoir, :respect:

Encore un schéma, du genre schéma de câblage, à ma sauce :icon_confused:, en ayant pompé des infos et des dessins sur le forum cw.

J'ai essayé de mettre le câblage au complet avec les détails sauf en ce qui concerne les câbles fournis par Gen.

Growduino03.thumb.jpg.2c061527f9ff848b0fdb2d657aad0c52.jpg

 

Pour l'instant, un seul point d'interrogation au sujet de la connexion des prises externes. Le neutre de la prise doit-il aller au neutre "général" venant de l’alimentation générale en 220v ?

A propos des fils :

- dimension : de 2,5mm pour tout ce qui est 220v, 0.75 pour le reste.

- couleur : les fils rouge, noir, bleu et vert de mon schéma sont-elles correctes ?

- ne prendre que des fils souples (galère si trop rigides)

 

Pour l'implémentation dans le boitier, je vais copier sur ce qu'à fait Gen dans son tuto "Mise en boitier"

Du coup,  il va falloir que je me procure une extension de natte pour le LCD et le kb. Si quelqu'un a des références de prolongateurs tout faits, je prends ! :rolleyes:

 

J'ai aussi l'impression que le bornier de distribution 5v et gnd n'est plus nécessaire, le Groduino fournissant ces signaux aux platines ? :siff:

 

A part ça, j'attends toujours le transfo 5v,donc pas de mise sous tension jusqu'à maintenant. Par contre, j'ai trouvé une personne pouvant me prêter du matos Dremel.

J'attends d'avoir un peu plus de concret à faire avant de lui emprunter.

 

En plus du transfo 5v, j'attends les prises extérieurs (des shuko-s) et le relai SSR pour la lampe.

 

En fin de semaine je dois aller en ville :yepah:(ça ne m'arrive pas tous les mois !), ville assez importante, et j'imagine y trouver un magasin d'électronique pour continuer mes emplettes : cables, vis, presse-étoupe, entretoises, fil d’étain et fer à souder, cosses et pince à sertir, etc ...

 

Peace. Cyberius. :kana_smile:

 

 

 

 

 

 

 

Edited by cyberius
Modif schéma : suppression des "?" pour le fil neutre des prises externes - Ajout du SSR (sur Timer1)
Link to post
Share on other sites

Bonjour , salut , ola , plop, 

Un petit message pour suivre le projet

 

Bye , a+ , +++

Edited by croquemou
La politesse n'est pas une option , on est pas chez même ou avec ces pote dans la cours du lycée agricole de Mouzon les Bleuvinette
  • Like 1
Link to post
Share on other sites

Yop

 

Mets ton SSR lampe sur TIMER 1, C'est lui qui détermine les calculs jour/nuit pour toute la gestion.

 

Pour l'instant, un seul point d'interrogation au sujet de la connexion des prises externes. Le neutre de la prise doit-il aller au neutre "général" venant de l’alimentation générale en 220v ?

 

oui

 

A propos des fils :

- dimension : de 2,5mm pour tout ce qui est 220v, 0.75 pour le reste.

 

oui

 

- couleur : les fils rouge, noir, bleu et vert de mon schéma sont-elles correctes ?

 

on s'en fout,  (bleu neutre, noir/brun phase)

 

- ne prendre que des fils souples (galère si trop rigides)

 

clair!

 

Pour l'implémentation dans le boitier, je vais copier sur ce qu'à fait Gen dans son tuto "Mise en boitier"

Du coup,  il va falloir que je me procure une extension de natte pour le LCD et le kb. Si quelqu'un a des références de prolongateurs tout faits, je prends !

 

ebay est ton ami.. ref câbles Dupont (là tu pousses un peu !!)

 

J'ai aussi l'impression que le bornier de distribution 5v et gnd n'est plus nécessaire, le Groduino fournissant ces signaux aux platines ?

 

exact, il n'apparaît plus dans mon schéma

https://www.cannaweed.com/forums/topic/220050-growduino-v3-final-guide-et-mise-en-oeuvre/

 

++

GEN

 

Edited by Gen
  • Like 1
Link to post
Share on other sites
Il y a 12 heures, Muth a dit :

Bonjour , salut , ola , plop, 

Un petit message pour suivre le projet

 

Bye , a+ , +++

Bonsoir Muth,

Pas de problème. Dans ce fil de discussion,  je vais raconter la mise en œuvre du Growduino pour mon "petit" projet.

Pour info, je ne suis pas électronicien donc ça peut-être intéressant pour un néophyte (ou quasi néophyte).

J'y vais doucement et les schémas aident bien à éviter les bêtises.:chim:²

Essaie de suivre également les fils de discussion suivants :

growduino-v3-final-guide-et-mise-en-oeuvre

growduino-zone-de-partage

mise en boite d'un mini Growduino

Peace. Cyberius.

 

Edited by cyberius
Link to post
Share on other sites
Le 14/02/2019 à 20:53, cyberius a dit :

Bonsoir Muth,

Pas de problème. Dans ce fil de discussion,  je vais raconter la mise en œuvre du Growduino pour mon "petit" projet.

Pour info, je ne suis pas électronicien donc ça peut-être intéressant pour un néophyte (ou quasi néophyte).

J'y vais doucement et les schémas aident bien à éviter les bêtises.:chim:²

Essaie de suivre également les fils de discussion suivants :

growduino-v3-final-guide-et-mise-en-oeuvre

growduino-zone-de-partage

mise en boite d'un mini Growduino

Peace. Cyberius.

 

Hello,

Merci pour les infos supplémentaire.
je ne suis pas électronicien non plus, mais je suis informaticien par contre. 
Chez moi je bricole déjà du arduino + raspberry pi pour faire de la domotique. Et je me suis souvent pauser la question d'utiliser un système identique pour géré le climat de mon jardin :)

 

++

  • Like 1
Link to post
Share on other sites

Bonjour, :smile:

Juste une petite mise à jour parce qu’il n’y a pas grand-chose de neuf.

Quand même, la grande nouveauté est que j’ai reçu le transfo 220v/5v ce qui m’a permis de mettre le Growduino sous tension … et il est vivant. :roll:
Des petites lumières s’allument sur le shield et les trois pages d’écran dites A, B et C (affichage d’infos globales, spécifiques au climat et spécifiques aux relais) fonctionnent correctement. De même que l’utilisation des touches A B et C pour passer de l’une à l’autre.

Test1.jpg.9e54605a5ae870f79d5835a30f047fe8.jpgTest1b.jpg.eec6477f77cd9bc46db030cde8c541fe.jpg

Par contre, je n’arrive pas à rentrer et naviguer correctement sur le menu de setup.  Le menu s’affiche et disparait aussitôt (pas le temps d’utiliser les touches du clavier que le menu disparait pour laisser la place à un des écrans A, B ou C). A voir donc !

Pour en arriver là, je n’ai connecté que le transfo 5v, Growduino, l’écran et le clavier … soit le minimum. 

Je n’ai pas encore commencé à toucher au grand boitier mais tout ce qui doit être encastré sur celui-ci est, soit commandé, soit déjà reçu. Je ne vais pas tarder à commencer le travail manuel. :roulage:

Ci-dessous, une liste du matos nécessaire à mon projet. Ce qui me pose le plus de problème ce sont les petits trucs, genre fil, vis, connecteurs, etc … mais ça progresse bien quand même.

Matos.jpg.5a901d4eaa90472f3cb69644951fa99a.jpg
Pour les outils, je devrais les trouver dans les magasins du coin, du coup j’attends d’être sûr d’en avoir besoin pour me les procurer.

Pour la sonde, comme je n’ai qu’un capteur température/humidité, je vais probablement me simplifier la vie en essayant de connecter directement le DTH22 à un connecteur et y connecter les 3 fils venant du Growduino. Tout ça dans un petit boitier. Faisable ? :lire:

Peace. Cyberius.

  • Like 2
Link to post
Share on other sites
Il y a 11 heures, Muth a dit :

Hello,

Merci pour les infos supplémentaire.
je ne suis pas électronicien non plus, mais je suis informaticien par contre. 
Chez moi je bricole déjà du arduino + raspberry pi pour faire de la domotique. Et je me suis souvent pauser la question d'utiliser un système identique pour géré le climat de mon jardin :)

 

++

Bonsoir, :kana_smile:

Dans ce cas, tu es au bon endroit. Je crois le système suffisamment ouvert pour que tu puisses le modifier ou le customiser à ta sauce.

Dans la partie "zone de partage" une personne y a même ajouté le nécessaire pour y gérer la wifi (ou bluetooth ?).

Informaticien ! me too ... mais c'est fini, je suis libéré de mes obligations professionnelles. :high:

Peace. Cyberius.

Link to post
Share on other sites

yop

 

Tu n'as pas de rétro-éclairage..

à contrôler :

 

1-tension de sortie du transfo au multimètre a régler sur 5.01v en charge

(Attention, comme l'alim rentre directement sur le 5V de l'arduino, si tu dépasses 5.5V, tu crames le contrôleur)

2-présence du jumper à l'arrière du LCD

3-reglage de la luminosité LCD avec le petit potar bleu à l'arrière.

 

Le fait que ton clavier déconne est dû à une mauvaise tension d'alimentation ou un mauvais contact du clavier au shield

 

++

GEN

Edited by Gen
  • Like 1
Link to post
Share on other sites

@cyberius  Yo!  OH STYLÉ  ! des controler en Arduino !

 Je me voulez m'y attelait mais c'est déjà fait , Un Grand Merci pour toutes ces Précieuses infos ! Good JOB !

 

J'ai de quoi lire et fouiner je crois ! ?

a très vite avec les questions en prime  ! Mouahah

 

 

 

 

 

 

Edited by PprWildeStyle
  • Like 1
Link to post
Share on other sites

Bonjour, :roll:

Déjà une semaine depuis le dernière mise à jour et pas énormément de progrès sur ce projet. Il faut dire que nous avons eu une semaine de printemps en plein hiver et j’ai privilégié les activités de plein air. Normal, l’occasion était bonne. :yepah:

Néanmoins, au niveau bricolage du boitier, j’ai bien avancé.
Les prises électriques latérales sont installées (côté droit du boitier) ainsi que les presses étoupes (en dessous) et le bouton Reset (côté gauche).
Les évidements pour encastrer le clavier et l’écran sont prêts. Il ne manque plus que ceux de l’afficheur de consommation et du bouton ON/OFF (commandés mais non reçus) à faire.
De même, j’ai préparé les fils pour relier la platine moteur et l’auto-transfo.

 

PriseElec.jpg.3c00ef2c2da3d9f3fe666aa843d76e49.jpgPresseEtoupeSonde.jpg.1b08fda9c4bcf18ec7fc1496821a1984.jpgBoutonReset.jpg.aad44770aaee79b03ed659d840438833.jpg

Note : le petit boiter orange est une récup (Kinder ?) qui va servir pour la sonde.

Par contre, niveau électronique, c’est plutôt la cata. J’ai remis en route le système comme la première fois (juste alim 5v, Growduino + lcd +kb) sans avoir fait quelque chose de nouveau sauf ajouté le jumper de rétro-éclairage … et bien plus rien ne se passe à l’écran. En tournant le potar d’intensité lumineuse du lcd, des carrés noirs s’affichent … c’est tout.
Le rétro-éclairage est bon.

 

GroduinoKb.jpg.1f2125d14c99074826a85f0fe0d71fb3.jpgLCDout.jpg.1620a426c0931dfdf7d8ae3ec71e9395.jpg

Mon voltmètre, dont l’affichage est peu précis, indique un peu plus de 5v et moins de 5.5v (tension prise sur les plots alim du Growduino. J’ai beau tourner le potar de réglage de tension de l’alim 5v  pour faire varier  la tension entre  4.8V à 5.3V (à peu près) et rien n’y fait.  :icon_confused:

Un indice ? A l’arrière du lcd, une led rouge est allumée.

Sur le Growduino, les Leds sont comme ceci :

Jaune    Jaune

Vert       Vert       (ou éteint éteint)

Eteint    Bleu

Rouge   Eteint

Et comme bien sûr, je n’ai pas de matos (analyseur logique etc.) pour observer les signaux. Du coup, je suis un peu coincé (pour le moment :lire:) sur cet aspect-là.

Peace. Cyberius. :kana_smile:

Edited by cyberius
Link to post
Share on other sites

yop

 

est ce que le shield est bien enfoncé sur l'arduino, les pin mâles sont-elles bien dans les dupont femelles ?

as-tu essayé un reset?

le connecteur 4 pin du lcd est bien enfoncé à fond ?

++

GEN

Edited by Gen
  • Like 1
Link to post
Share on other sites

Yop,

 

J'ai eu le même soucis. Pas moyen d'avoir quoi que ce soit à l'écran si je ne branchais pas simultanément l'alim 5V et le port USB de l'arduino. C'était avec la V2 du shield. Je suis passé à la V3 et plus de soucis. Cela fonctionne avec l'alim 5V.

 

Essaye en alimentant via le shield et via le port USB en même temps...

 

A+

  • Like 1
Link to post
Share on other sites

yop

 

Étrange ce que tu dis car l'entrée de l'arduino ou le Vin passent par un régulateur de tension 5V et pour que le régulateur sorte 5V il faut au moins rentrer avec du 7V

Donc normalement le régulateur débitera bien en dessous de 5V si il en reçoit 5 en entrée.

Le matos a été testé avant expédition et à fonctionné à la réception.. SI le problème ne vient pas d'un des points précités, je pencherai sur une erreur de polarité à la connexion

 

++

GEN

Link to post
Share on other sites

Bonsoir, :rolleyes:

Bonne nouvelle … ça marche, l’écran d’accueil s’affiche correctement. :high:

LCD2.jpg.6702a1c95fbd677e45e49eb4f68cdbd7.jpg

Nous avons pas mal galéré, ma femme et moi, pour y arriver. C’était un peu comme si on essayait de réparer un train électrique en panne ... :chim: avec réussite.

Tout simplement un (ou plusieurs)  fil soudé sur le LCD (et venant du shield) faisait un mauvais contact.

Avec le montage à l’arrache qui est en photo ci-dessous, utilisation de dominos électriques qu’on avait sous le coude, nous avons stabilisé les contacts et c’était bon. Cool.

Bazar1.jpg.5c0e67ae2bd53d3cfa96c2dfd36409a3.jpg

Faute de temps, nous n’avons pas continué les tests. Nous n’avons pas été plus loin que l’écran d’accueil. Donc, à suivre …

Peace. Cyberius. :kana_smile:

Link to post
Share on other sites
  • 2 weeks later...

Bonsoir, :respect:

Une bonne semaine est passée depuis ma dernière maj. J’ai passé deux matinées à bricoler sur le projet et je trouve que ça a bien progressé. :rolleyes:

Sur le boitier, j’ai installé le bouton ON/OFF, ne manque plus que l’afficheur de conso (toujours pas reçu). Tout ce qui devait être fixé sur la plaque métallique (du fond du boitier) est maintenant fixé.

20190310_130635.jpg.97219560648d1c46a85a26a6fe518b3e.jpg20190310_130504.jpg.a4c6c96087a41ed4a62dc2896c4aa81a.jpg

J’ai connecté tout le 5v, comme sur la photo ci-dessous et ça fonctionne. L’écran et le keypad sont installés sur la face avant du boitier et sont connectés avec des prolongateurs de câble.

20190310_130405.jpg.6876850272aa5ce00169b233c8094449.jpg

Pour l’instant j’ai utilisé les cables de mes nappes ayant des connecteurs Dupont, donc pas forcément conseillés car un peu instables. Il va falloir faire quelques choses pour trouver les bons connecteurs !  :icon_confused:  :lire:

Quelques photos sur ces connections :

Le timer2 (pour la lampe) et les autres relais (cable de Gen temporairement (?) remplacé) -- Passage de 8 sorties à 4 sorties

 

20190310_130843.jpg.c0f66d5675d1087316a85a5e3a2432ea.jpg

Relai SSR pour la lampe

20190310_131006.jpg.e57d9fccce8ae6622ca4ca2812deffed.jpg

Raccord Keypad

20190310_131723.jpg.1358afe2a1b757621ac2505c1e88c54a.jpg

Connections lcd

20190310_130911.jpg.f8efb4b8444f436057160863a4be83da.jpg

Raccord lcd (à gauche, le transfo 5v)

 20190310_131805.jpg.fc5990a5776dceb9fdb7b5b8c9205ac1.jpg

Relai 4 sorties

20190310_131831.jpg.29edec3d8317ea35f4bc7dfe3e8a0551.jpg

Partie moteur extracteur (pas de Dupont cette fois-ci, mais va falloir peut-être sertir des cosses ?).

20190310_130956.jpg.93001fc32a6eb694d67f8b57dce03908.jpg

Peace. Cyberius.  :kana_smile:

  • Like 1
Link to post
Share on other sites

Yop

 

En français dans le texte et pour la seconde fois...

METS LE RELAIS SSR DE TA LAMPE SUR TIMER1   CAPPICHI ?

(Dis moi si c'est assez grand pour que tu l'enregistres :-) )

 

++

GEN

Edited by Gen
  • Like 1
  • Haha 1
Link to post
Share on other sites

Salut Gen, :smile:

Je te rassure, c'est écrit  suffisamment grand ... et puis en rouge ... impossible de zapper cette fois-ci, même moi . :idea:

En fait, comme le paramètre delay, l'attente avant tentative de ré-allumage est après le timer 2, je pensais qu'il fallait utiliser ce dernier.

Je vais modifier, pas de soucis.

Pour le reste, pas mal quand même ... en tout cas, je suis content d'en être arrivé là. :yepah:

Un de ces jours, je vais regarder le prog Growduino et essayer de comprendre plus précisément comment sont gérés les équipements. Si je pige bien, je ferais une doc.

Prochaines étapes :  la sonde, sceller la plaque de fond du boitier puis cabler le 220V, puis tester le paramétrage des prises en utilisant une simple lampe de chevet.

Tout ça avant de déplacer le boitier Growduino près de la box et de passer en réel.

Du pain sur la planche :chim:

Peace. Cyberius.:kana_smile:

Link to post
Share on other sites