Discussion Beta Testeurs du PROTO [TERMINE]


Messages recommandés

yop

 

Non..  mais tu es le seul a avoir ce problème

les platines fonctionnes

donc regarde du coté de la config et ou des contacts

 

++

GEN

Lien à poster
Partager sur d’autres sites

Salut

Par contre quand j'ai deux barres vertes je suis sur la vitesse 1 sur la platine relais !!!

Les autres peuvent ils confirmer que leur platine relais moteur se met bien en vitesse 1 sur la première barre verte et que ça reste en vitesse 1 sur la première barre verte et non que ca coupe les moteurs ?

Merci

 

 

 

Modifié par Bib60
Lien à poster
Partager sur d’autres sites
Le 07/07/2018 à 20:23, Gen a dit :

yop

 

tu as mesuré sur les soudures ?

sinon tu changes de pin pour le co2

tu utilisersa RES.2 comme sortie CO2 et tu modifies dans le code ligne 46

tu remplaces

#define CO2_OUTPIN        A8  // CO2

par

#define CO2_OUTPIN        13  // CO2

 

et tu recharges le programme

 

++

GEN

 

Salut

J'ai essayé mais après upload plus de déclenchement de l'icone CO2.

Il me semble voir que la sortie 13 est déjà utilisé en ligne 54 pour le PH_UP

Merci

 

Lien à poster
Partager sur d’autres sites

Merci Gen

Du coup j'ai pris la sortie 19 qui correspond au pin Resa 4 mais toujours impossible de déclencher le fonctionnement du CO2, l’icône ne s'allume plus. 

Il y a des conditions pour enclencher le CO2 ?

Merci

Lien à poster
Partager sur d’autres sites

Salut

Ok c'est bon mais idem sur le pin Resa 4, au déclenchement je n'ai que 0.5V

J'ai pris la précaution de désactiver tous les autres relais pour voir si c'était un problème de chute de tension.

@+

Modifié par Bib60
Lien à poster
Partager sur d’autres sites

Bonjour   

 

J ai le meme probleme  concernant la sortir Co2  ne declenche pas le relais.

j ai controler le relais il fonctionnne ,  a voir  je fais effectuer les test plus  et verifier mes contact et  sortie du a8

 

je vous tien au jus 

Lien à poster
Partager sur d’autres sites

bonjour,

 

Après avoir lu les commentaire sur vaut problème relais C02, je me suis dit qu'une petite vérif s'impose.

Sa fait 15 jours que j'ai pas allumé le proto, et déjà je me suis rendu compte que tout les relais s'allument bien au démarrage sauf celui du C02.

Après une fois que le systeme Co2 s'active tout marche bien, l'icone est en verte, l'extraction est bien coupé et se rallume bien quand il faut, bref aucun soucis a par le relais qui se déclenche pas.

Le relais n'est pas mort vu que j'ai test de le branché sur autre chose et il fonctionne.

Pourtant je suis persuadé que le relais Co2 marché l'autre jour, je devais surement pas être très frais.

 

Voila surement pas grand chose, en attendant la suite.

 

A plus

Lien à poster
Partager sur d’autres sites

yop

 

La mise à jour avec correctif CO2, pH et graphique sera normalement dispo lundi 23.

Ce sera la dernière. ensuite j'attaquerai la finalisation du shield DUE

 

++

GEN

 

 

Lien à poster
Partager sur d’autres sites

Yop

 

Désolé j'ai pris un peu de retard..

Bonne nouvelle la programmation est terminée :-)

 

- CO2

- Cuve et remplissage

- Temp auxiliaire (DS18B20)

- Graphiques  T° et Hr

- Bug affichage paramètres cuve

- PH

 

Je teste tout ça et je vous reviens d'ici qlq jours

 

++

GEN

Lien à poster
Partager sur d’autres sites
  • 2 semaines après ...

Mise à jour

 

proto.JPG

 

 

 

Modifications à faire 

Copier sur la carte SD les 2 fichiers dans l'archive ci-dessous (copier le pdf, renommez le .zip, décompactez le)

images.pdf

 

Attribution des sorties:

RES1 = température auxiliaire UP

RES2 = température auxiliaire DOWN

RES3 = water (remplissage automatique de cuve)

 

Le programme complet sous ATOM (copier le pdf, renommez le .zip, décompactez le)

proto.pdf

 

mise en oeuvre des nouveautés:

 

appuyez au centre de l'écran, et celui-ci basculera en mode archivage

ré-appuyez dessus qlq secondes et il repassera en mode normal

grapjh.JPG

le tableau représente les valeurs circulaires sur 24Hr

la ligne rouge défini le moment actuel

les valeurs sont archivées tous les 15min à terme échu

 

le co2 est fonctionnel

 

le remplissage automatique est fonctionnel

introduisez les valeurs de distance en prenant comme point de départ la sonde

 

RESET du min et du max temp et hr sur l'écran principal en appuyant quelques sec sur la valeur à 'RESET-er'

 

écran paramètres opérationnel

prise verte = activé

prise grise = désactivé

 

flèche verte vers le haut = relais actif à l'état haut

flèche verte vers le bas = relais actif à l'état bas

 

ATTENTION.. Si vous utilisez des platines relais et non des platines moteurs pour la commande des autotransfo, déconnectez les platines avant de configurer vos paramètres, rebranchez les ensuite.

 

Le PH n'est pas encore opérationnel car lors des tests j'ai remarqué que le programme se figeait si l'on calibrait sans sonde branchée.

Je réglerai ce problème ce WE

 

++

GEN

Modifié par Gen
Lien à poster
Partager sur d’autres sites

Salut.

 

Cool une Maj.

Bon le code c'est  téléversé sans aucun problème, Pour une fois Atom ne ma pas fait galérer.

 

Premier retour vite fais, le relais Co2 s'active bien maintenant, et le mode archive graphique s'affiche bien aussi.

Du coup l'archive se reset tous les jours, et se qu'il y a un dossier dans la sd qui se créér pour gardé tous l'archive de la culture ?

En tout cas bien sympa se ptit mode.

 

Attribution des sorties: RES3 = water (remplissage automatique de cuve), pourtant y'a deja une Pin water, c'est pour autre chose ?

 

Du coup se week je commencerai le test de la partie remplissage.

Je me demandais, est se que on peut commencé a mettre des prises sur les relais, histoire de test le remplissage de ma cuve pour voir se que sa donne, ou c'est encore trop tot.

 

En tout cas, comme d'hab, jolie boulot, bon week.

Lien à poster
Partager sur d’autres sites

yop

 

Nop, sur le proto il n'y a pas d'archivage au delà d'une mise en mémoire vive sur 96 positions.

Le shield final, lui aura de la RAM pour pouvoir archiver sur de grandes périodes

par contre il ne se reset pas toutes les 24hr.. c'est en lecture continue, càd que ce qui se trouve à droite de la ligne rouge provient de la veille

 

la sortie water est inopérante, et remplacée par RES3

 

oui tu peux brancher tes relais sans problème.; bien veiller au paramétrage de ceux-ci via la page paramètres

 

merci :-)

 

++

GEN

Modifié par Gen
Lien à poster
Partager sur d’autres sites

Bonjours la Room

 

HOOOO   GEN   trop  cool  en plus   tu as mis temp AUX  haut et bas  ,,   j vais  pouvoir  gerer l intra  avec la temperature  exterieur   du coup  si  sa depasse  27  coupe l intra et aspire  le bonne air viscier de  la cave  mais qui  reste  frais ,  la nuit  le bonne air frais de l exterieur,

 

ces une  configuration 

 

j aime  j aime  j aime  

a bientot la room  je taff dessus se wk comme un fous

Modifié par Jim1427
Lien à poster
Partager sur d’autres sites

yop

 

Sur le shield final, il y aura 2 sondes, une interne et une externe, et le programme gérera les appels d'air en fonction de la t° extérieure

 

++

GEN

Lien à poster
Partager sur d’autres sites

Yep 

 

Gen  tes trop fort

 

alors  petit nouvelle 

 

mise a jour televerser  fichier copier sur sd ( succes ) comme d hab sa devient easy

je confirme  co2 fonctionnel a tous les point vue ,   notre cher relais également.

 

et tous le reste fonctionnais déja

 

euh oui,  l ultra son fonctionne, les valeur correct

Comment ta fait  gen  c etait quoi le prob ??

 

 

le Graphique nickel  i love it

je revient tres vite a

tchuss

 

 

Lien à poster
Partager sur d’autres sites

Yop

il y a 31 minutes, Jim1427 a dit :

Comment ta fait  gen  c etait quoi le prob ??

 

De l'amour, des neurones, du travail :-)

le problème était une ouverture de port manquante.

++

GEN

Lien à poster
Partager sur d’autres sites
  • 1 mois après ...

yop

 

Fin de projet.

voici la dernière version proto_final.pdf (à télécharger et renommer en .zip)

Si vous avez terminé le chargement du programme et que vous ne désirez pas changer le code, il vous faudra changer le jumper du RESET SETTING.

 

R3S.png

 

1.JPG

 

une fois le jumper changé de place ou un pont de soudure effectué sur les 2 plots en partant de la gauche, vous ne pourrez plus charger de programme.

(ou alors il faudra revenir à la position initiale.)

Une fois cette modification faite, l'horloge ne se remettra plus à zéro lors des reboot.

 

++

GEN

 

FIN DE L'AVENTURE .. LA SUITE AVEC LE SHIELD DUE (Projet GENESIS)

 

Modifié par Gen
  • Like 1
Lien à poster
Partager sur d’autres sites

yop

 

Ca veut dire que j'ai arrêté le développement du proto, j'ai tous les enseignements nécessaires pour le produit finalisé qui sera GENESIS (le shield DUE)

Sortie prévue normalement fin d'année.

 

Merci .

 

++

GEN

Lien à poster
Partager sur d’autres sites

Yep

Cool ;-)

Une petite question concernant les platines relais moteur, tu proposes une nouvelle version pour le DUE, elle apporte quoi comme nouveauté par rapport à la version précédente ?

Tes premières version seront elles compatibles avec le DUE ?

Merci Gen

@+

Lien à poster
Partager sur d’autres sites