GROWDUINO [Zone de partage]


Recommended Posts

Yop

 

Si le 2.4GHz passe très bien alors c'est parfait.

En effet rien ne m'empêche de modifier le circuit, mais est-ce le but?

Faire un autre circuit signifie s'isoler du projet commun.

Alors que partir d'un circuit commun et modifier le code fait avancer la communauté.

Du coup, sur le futur projet quels sont les pins accessibles pour ajouter d'autres matériels?

Exemple si je veux mettre un écran lcd 24x2 à la place de nextion où puis-je le brancher si je veux faire évoluer ma box Growduino V3 en Genesys?

Jusqu'à présent il y avait, avec les shields, plein de pin libres pour ajouter ce qu'on voulait et je trouve que cela manque sur le Genesys.

(Je précise Gen qu'il ne s'agit pas d'une critique mais juste d'un constat. Je respecte tes choix mais m'attriste des conséquences)

 

++

 

Viker

Link to post
Share on other sites

Bonjour,

 

je viens de tester le filtre anti parasite et les condos toujours plantage !

je devrais recevoir des relais ssr cet après midi ; je vais faire un essai avec .

j ai regarder au multimètre les variations de tension au bornes du shield quand le relais s active il  a une petite chute  de qq mV .

une question est ce normal que l affichage de l heure soit erratique ,et que les cycles ne soit  pas très stable en durée ? ou est ce un indice de plantage ?

encore merci de votre aide.

 

++

 

 

 

Link to post
Share on other sites

Bonjour,

 

il faudrait plus de précision. Ta chute de tension passe de combien de volts à combien de volts?

Essai de passer sur ta deuxième alimentation pour voir si cela fait une différence (et si elle est sous dimensionnée utilise seulement un seul relais)

Que veux-tu dire par un affichage erratique? Si l'affichage des secondes n'est pas fait chaque seconde ce n'est pas un bug car le lcd fait un refresh non synchronisé à l'horloge.

Par contre que les cycles ne soit pas stable en durée ce n'est pas un comportement normal.

 

++

Viker

Link to post
Share on other sites

Bonjour greenbruno,

Si tu vois quelques millivolts de chute avec un multimètre numérique, c'est qu'en réalité il y en a des centaines. Un multimètre numérique est très long en affichage.
Quelle alimentation utilises-tu pour ton Growduino? il en faut une de minimum 1.5 à 2 Ampères et si possible le plus stable possible.
Si ta tension chute en dessous de 4,65V, le décrochage des microcontrôleurs est quasiment automatique même si cela ne dure qu'une milliseconde.
Il est aussi possible que ce soit simplement ton afficheur qui décroche et fasse planter ton Growduino.
essaie de mettre;
1 condensateur de 10 à 47µF juste en arrivée sur ton afficheur + 1 de 100nF pour les hautes fréquences.
1 de 47 à 220µF + 1 de 100NF^à l'entrée alim du growduino.
1 de 100 à 220µF en parallèle avec 100nF sur ta carte Relais.

Soit sur que tes masses soient bien reliées entres-elles et en étoile à partir de ta sortie d'alimentation.

Avec ça et une alimentation convenable, tu ne devrais avoir aucun problème de parasite qui transite.

Bon courage pour la suite.

  • Thanks 1
Link to post
Share on other sites

Yop

 

Ce qu'il devrait faire c'est contrôler en plus du 5V , le 3V3 car le processeur fonctionne de 2V3 à 3V3.

maintenant ceci n'exclus pas l'autre, en sachant que le GENESYS possède un régulateur 3V3 et toute sa clique de condos, cependant, pour qu'un régulateur fonctionne correctement, on dit en général qu'une tension d'entrée doit être de 2V supérieure à celle de la sortie.

Mais pour l'instant je n'ai remarqué aucun soucis de ce coté là, vu la tension min nécessaire

Dans le futur, je ne réaliserai que des circuit 9V afin de pouvoir contrôler et réguler avec efficience les 5V et 3V3.
pour moi, je suis quasi persuadé que cela provient de son alimentation.

 

++

GEN

Link to post
Share on other sites
Il y a 2 heures, Viker a dit:

Yop

 

Si le 2.4GHz passe très bien alors c'est parfait.

En effet rien ne m'empêche de modifier le circuit, mais est-ce le but?

Faire un autre circuit signifie s'isoler du projet commun.

Alors que partir d'un circuit commun et modifier le code fait avancer la communauté.

Du coup, sur le futur projet quels sont les pins accessibles pour ajouter d'autres matériels?

Exemple si je veux mettre un écran lcd 24x2 à la place de nextion où puis-je le brancher si je veux faire évoluer ma box Growduino V3 en Genesys?

Jusqu'à présent il y avait, avec les shields, plein de pin libres pour ajouter ce qu'on voulait et je trouve que cela manque sur le Genesys.

(Je précise Gen qu'il ne s'agit pas d'une critique mais juste d'un constat. Je respecte tes choix mais m'attriste des conséquences)

 

++

 

Viker

Yop

 

Ben le but du jeu en open source, c'est que tous le monde participe en fonction de ses moyens et de ses besoins..

concernant les sorties, tu n'as que l'embarras du choix, tu peux utiliser des mux I2c et des MCP ce qui pourrait te fournir

tout ce que tu veux. Car toutes les I/O sont occupés

"Je respecte tes choix mais m'attriste des conséquences"

Mais je pense que tu n'as pas bien compris ma vision des choses, les shields c'est pour les bricoleurs/bidouilleurs, les circuits finis c'est pour les non bricoleurs.

Mais encore une fois, c'est de l'open source, donc vous avez le code et les schémas, vous en faites ce que vous voulez, Perso je ne suis pas ici pour faire du sur-mesure au cas par cas, je pourrai le faire, mais alors le prix sera à 4 chiffres si tu vois ce que je veux dire, cependant je suis pas ici pour faire du pognon, sinon j'aurai ouvert une boîte et n'aurai absolument rien partagé. Comprends-tu ? ;-)

 

++

GEN

 

Edited by Gen
Link to post
Share on other sites

Re,

la tension passe de 5,01 a 5,00V j ai augmenter la tension de sortie pour compenser la perte?

je tourne sur 1 relais

mon alim sort du 5v 3 Ampères (suivant les recommandations de Gen) .Avec l alim du tel la chute est plus brutal;

 

++

Link to post
Share on other sites

Re,

 

Tu peux aussi vérifier toutes tes soudures du coté de l'entrée d'alimentation, il peut y avoir un défaut de ce coté la.

Si ton alimentation fait 3A, inutile d'essayer avec une de PC, tu auras les mêmes soucis.

vérifie plus ton câblage si ça ne donne rien coté soudures et tes connecteurs de liaison.

A+.

Link to post
Share on other sites
il y a une heure, greenbruno a dit:

Re,

comment tester ? une alim de pc ?

mon relais SSR ne commute pas non plus juste la diode !

 

++

 

yop

 

Qu'entends-tu par ne commute pas, tu testes comment ?

 

++

GEN

 

 

Link to post
Share on other sites

Yop

 

"Ben le but du jeu en open source, c'est que tous le monde participe en fonction de ses moyens et de ses besoins.."

Je suis complètement d'accords et ne remet pas en question cela. ?

 

"Mais je pense que tu n'as pas bien compris ma vision des choses, les shields c'est pour les bricoleurs/bidouilleurs, les circuits finis c'est pour les non bricoleurs."

Ben si justement j'avais très bien compris ton choix de faire comme cela mais de ce fait je trouvais que d'ajouter sur le circuit des pins pour les I/O restantes pouvait ainsi concilier les deux mondes des bricoleurs et des non bricoleurs.

" je ne suis pas ici pour faire du sur-mesure au cas par cas"

Du coup ce n'était pas de faire du sur-mesure mais juste un accès universel pour tout bricoleur afin que chacun y mette sa déclinaison libre. Donc un seul schéma pour tout le monde.

"Car toutes les I/O sont occupés"

C'est une très bonne raison pour ne pas avoir ces pins supplémentaires et donc ma remarque n'a plus de sens :boulet2:

 

"je suis pas ici pour faire du pognon, sinon j'aurai ouvert une boîte et n'aurai absolument rien partagé"

Je ne remettais aucunement ton intégrité en cause, je n'ai jamais dis ni même pensé cela et ce n'était point le propos de mon message. ;-)

 

++

Viker

Link to post
Share on other sites
il y a 4 minutes, Viker a dit:

ce n'était point le propos de mon message. ;-)

 

Yop

 

J'entends bien mon lapin.. Cela n'avait aucune connotation de quel qu'ordre que ce soit

 

++

GEN

Link to post
Share on other sites
Il y a 1 heure, Gen a dit:

Yop

 

Oui je pense que les alim sont la piste à suivre.

 

++

GEN

 

Il y a 1 heure, Lolo2805 a dit:

Re,

 

Tu peux aussi vérifier toutes tes soudures du coté de l'entrée d'alimentation, il peut y avoir un défaut de ce coté la.

Si ton alimentation fait 3A, inutile d'essayer avec une de PC, tu auras les mêmes soucis.

vérifie plus ton câblage si ça ne donne rien coté soudures et tes connecteurs de liaison.

A+.

 

Yop,

 

en effet avec tous les symptômes y'a des chances que l'alimentation ou les connexions entre l'alimentation et le shield soient en causes.

Ta première alimentation a peut être des tensions non stables.

Ta deuxième alimentation a peut être un courant trop juste.

++

Viker

Edited by Viker
Link to post
Share on other sites
Le 25/02/2020 à 12:04, greenbruno a dit:

Bonjour,

j ai un souci avec mon Growduino , j ai réalisé une petite vidéo du problème https://youtu.be/KSEtfDg3-00

a vous lire 

cdt

Bruno

Salut @greenbruno

Pour répondre à ta question. J'ai eu également le même souci avec une version antérieur de ton Growduino.
Tout simplement, change de carte relais (j'avais aussi une Made In China) et ça merdait tout le temps.
Prend une carte High Level non chinoise, et ton souci sera réglé. Voir même si @Gen n'en a pas de son coté également.

 

Edit:: tu peux garder ta carte chinoise, mais alors pour régler ton souci, chaque sortie de la carte doit passer par une SSR. (c'était une autre idée que j'ai testée)


Au plaisir de t'avoir répondu.

Edited by BilouteDj
Link to post
Share on other sites

Bonjour,

Tout d abord un grand merci de votre aide à tous .

"Ce qu'il devrait faire c'est contrôler en plus du 5V , le 3V3 car le processeur fonctionne de 2V3 à 3V3.": ou teste t on cette tension ? (et d ailleurs que signifie le chiffre après le V )

J ai mesurer les tensions de commande du multipaire vers les platines 8 voies  : 4.79 V

                       les tensions de commande des sorties individuelles : 4.33 V (Les relais SSR ne commute qu aléatoirement ), je les test comme des interrupteurs en les plaçant sur la phase  du circuit  secteur qui alimente une ampoule a incandescence .

un remède fonctionnel est effectivement d alimenté les SSR en 5V (alim téléphone )commuté par la platine "chinoise" .

dans ce cas plus de plantage .

est ce une solution viable a terme ?

j irai faire mes courses de condos demain ;

 

voili voila 

 

encore merci à vous

 

++

Link to post
Share on other sites

Bonsoir,

 

2V3 à 3V3 cela signifie de 2,3V à 3,3V ;)

 

Si tu mesures une tension de 4.79V voire même 4.33V ce n'est pas bon, tu dois toujours avoir une valeur proche de 5V.

Ton alimentation principale n'est visiblement pas de bonne qualité.

Si tu alimentes les SSR en 5V avec une autre alimentation cela à pour conséquence de moins tirer sur ton alimentation principale qui du coup suffi à l'arduino.

Maintenant question de viabilité si dès le début l'alimentation n'est pas capable de fournir le courant demandé je doute sur sa fiabilité à long terme.

Change d'alimentation. Prends une meanwell cela devrait le faire.

 

++

Viker

Link to post
Share on other sites

Bonjour,

Grosse déception même symptôme avec la nouvelle alim !

Il faut que j augmente la tension de sortie aux alentours de 5.46V pour que le relais SSR commute le secteur(avec une ampoule qui clignote) ,même tarif avec le relais 8 voies qui lui plante le système  ;

bouhh

 

++

 

Link to post
Share on other sites

Yop

 

Ça me semble assez "lourdingue" cette histoire, il doit y avoir un "binss" quelque part.

Renvoie moi le circuit pour test, qu'on en aie le coeur net. Je ne dis pas que j'y regarderai de suite, car il y a du monde qui attend,

mais j'y jetterai un œil dès que possible.

 

Me MP pour les coordonnées

 

++

GEN

Link to post
Share on other sites
  • 1 month later...

Salut !

 

 Je cherche des informations sur l'électricité pour une mise en boite d'un Growduino, et donc une personne étant de préférence un professionnel dans le domaine :

 

 Posons les bases :

  • Je suis une grosse bille en élec' , je m'informe mais c'est pas un sujet a prendre à la légère du coup je cherche a avoir des conseils.
  • Sur le fofo' on trouve toutes les infos pour la mise en boite standard d'un Growduino ( schémas, références et lien des composants a ce procurer, diamètre des fils électriques etc ...) et jusque la tout va bien, pas de soucis de ce côté.
  • L’installation va ce composer grosso merdo d'un radiateur 500W, déshumidificateur 500W, 200W de lampe LED, environ 150w de ventilation diverses et quelques petits appareils içi et la pour moins de 150W.

=> Je cherche a y intégrer un disjoncteur et un différentiel pour sécuriser l’installation (et économiser un boitier type chantier ... )

 

En m'appuyant sur le schéma qui me sert d'exemple pour l'arrivée du 230V :

 

Révélation

schéma emprunté à  @BilouteDj içi GROWDUINO Zone de partage

 

Révélation
Le 16/06/2018 à 12:23, BilouteDj a dit:

Re,

 

Oui oui j'ai bien une HPS pour le T2.

 

j'ai refait le câblage et retirer un SSR, voici ce que ça donne.

Voici le schéma est actuel (en raccourcis), donc je ne l'utilise pas, j'attends que tout soit en ordre pour lancer le système.

montage.thumb.png.31260c8c80b5c285a01525e6de1f0e5d.png

J'ai reconnecté le carte 5V mais je ne sais comment comment la brancher, pouvez-vous m'aider à m'aider?

Et est-ce que la connectique du SSR est-elle correcte? J'ai d'énormes doutes que non (vu le relais 1 qui n'est nullement connecté).

J'ai pensé à ceci

5b24eb085bad6_Sanstitre.png.33a548a4fff836c9d640ce16ab2778f9.png


Merci d'avance pour votre aide apportée :)

 

Bonne journée à tous

 

 

 

gdno.png.e6119460501fd9672a467cc61369dbfa.png

 

Je comprend qu'ils sont a intégrés l'un sur l'autre à l'arrivée du 230v, jusque la je crois que je suis bon (?) .

 

J'aurais besoin de vos lumières sur le dimensionnement de ces éléments :

  • Disjoncteur 16A.
    • pour une installation de 1500W très grand maximum en prenant une bonne marge de 20%.
  • Disjoncteur différentiel 16A - 30mA

Cela vous parait correcte ou j'ai faux quelque part ? Auquel cas je suis preneur d'explication :)

 

++ !

 

 

Edited by SweetDreamsXAE5
Link to post
Share on other sites

Yop,

 

C'est cela. Il faut brancher dans l'ordre le differentiel de 30mA suivi du disjoncteur de 16A suivi de ton growduino. Ne pas mettre un differentiel de 300mA car il ne sera pas assez sensible pour une utilisation en milieu humide.

 

 

PS: les differentiels font 40A car en général, ils servent pour plusieurs disjoncteur dans un tableau électrique...

 

A+

  • Thanks 1
Link to post
Share on other sites

Re,

 

Attention à ne pas confondre disjoncteur différentiel et disjoncteur.

Le disjoncteur différentiel (celui de 30mA) déclenche en cas de perte de courant, de passage de courant à la terre et bien sur en cas de court-circuit franc. Il évite de jouer à Claude François dans sa baignoire...

Le disjoncteur (qui rempli le rôle d'un fusible) déclenchera en cas de sur consommation (essayer de pomper 3500W sur un circuit avec un fusible de 16A par exemple) afin d'éviter la surchauffe des câbles et bien entendu en cas de court-circuit franc.

 

Les deux sont indispensables mais ne remplissent pas la même fonction...

 

Il existe des bloc disjoncteur avec differentiel intégré disjoncteur-differentiel-modulaire-1pn-1

Edited by Ravier17
  • Like 1
  • Thanks 1
Link to post
Share on other sites